Terri ...
Here is one thing that might be causing the problem.

After you enable Content Advisor, sites that are not rated are also blocked. To change this setting, click the Users can see sites that have no rating option on the General tab in the Content Advisor dialog box.

Let me know if that works ... in the mean time I am still researching for you.